Jak ożywić BlipFoxa na Firefox4?

Na blipie pojawiają się często błędne informacje iż BlipFox nie działa na nowej wersji przeglądarki Firefox. Nic bardziej mylnego, działa i to bez większych problemów. Dlaczego jednak nagle po aktualizacji przestał działać? Chodzi tutaj tylko i wyłącznie o ustawienie kompatybilności programu z nową wersją przeglądarki.

Sam projekt nie ma się jednak za dobrze. Filip Tepper twórca BlipFoxa zakończył rozwój tego programu i poszukuje osób, które chciałyby nadal rozwijać ten projekt. Nie jest to dobra wiadomość dla fanów i użytkowników.

Mamy dwie możliwości uporania się z tym problemem. Możemy wyłączyć sprawdzanie kompatybilności dodatków, bądź ręcznie zmodyfikować odpowiedni plik BlipFoxa odpowiedzialny właśnie za informacje o najwyższej obsługiwanej wersji. Nie jest to ani czasochłonne, ani męczące. Sam osobiście wybrałem opcję drugą z racji na fakt iż mam kilka starych rozszerzeń, które nie działają za dobrze na Firefox 4. Dlatego też wolałem dostosować BlipFoxa do działania z nową przeglądarką niż na odwrót.

Wyłączenie sprawdzania kompatybilności dodatków

Przebieg konfiguracji w zrozumiały sposób opisał Wasacz we wpisie Jak wyłączyć sprawdzanie kompatybilności dodatków w Firefoksie?. Całość opiera się na dodaniu jednej wartości do konfiguracji przeglądarki.

Wprowadzanie zmian w about:config (konfiguracji przeglądarki) nie zawsze może wyjść na dobre. Wprawdzie opis ten nie powinien powodować żadnych skutków ubocznych, jednakże pamiętajcie, że robicie to na własną odpowiedzialność.

Ok, co musimy zrobić, by wyłączyć sprawdzanie pisowni?

  1. W pasek adresu wpisujemy about:config i zatwierdzamy.
  2. Klikając prawym przyciskiem myszy, wybieramy podmenu Dodaj ustawienie typuWartość logiczna (Boolean).
  3. Dodajemy wpis extensions.checkCompatibility.
  4. Ustawiamy mu wartość false.
  5. Restartujemy Firefoksa.
  6. Niekompatybilne dodatki powinny zostać włączone automatycznie (możliwe, że niektóre z nich naprawdę trzeba będzie wyłączyć).
  7. Aby móc pobierać i instalować wszystkie dodatki z addons.mozilla.org, zakładamy konto w serwisie.
  8. Po zalogowaniu uaktywni się nowa opcja dla starszych dodatków – Pomijaj sprawdzanie wersji.

Ustawienie kompatybilności BlipFoxa z nowym Firefoksem

Preferowane przeze mnie rozwiązanie z racji na prostotę. Opiera się on jedynie na modyfikacji jednej linijki z pliku konfiguracyjnego (właściwie, to pliku, w którym przechowywane są informacje dotyczące programu). Do całej operacji wystarcza nam jedynie Notatnik. Ok, koniec gadania, bierzemy się do roboty, bo marnuję tylko wasz czas.

  1. Klikając na Start wybieramy Uruchom. Tam wpisujemy %appdata%
  2. Następnie kolejno przechodzimy do: Mozilla\Firefox\Profiles\nazwa naszego profilu.default\extensions\{07498471-8DFE-45D1-B1E4-0839E613180F}
  3. Otwieramy w notatniku plik install.rdf
  4. Tutaj interesuje nas jedynie jedna linijka, zawierająca zapis em:maxVersion. Wartość powinna być równa 4.0.*, bądź nawet 4.*. Zapewniam jednak iż obecnie w zupełności sam zapis 4.0 zadziała!

Gotowy plik install.rdf do podmiany:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
<?xml version="1.0"?>
<RDF:RDF xmlns:em="http://www.mozilla.org/2004/em-rdf#"
         xmlns:NC="http://home.netscape.com/NC-rdf#"
         xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
  <RDF:Description RDF:about="rdf:#$Z8rup2"
                   em:id="{ec8030f7-c20a-464f-9b0e-13a3a9e97384}"
                   em:minVersion="3.5"
                   em:maxVersion="4.0.*" />
  <RDF:Description RDF:about="urn:mozilla:install-manifest"
                   em:id="{07498471-8DFE-45D1-B1E4-0839E613180F}"
                   em:name="BlipFox"
                   em:version="1.1.9"
                   em:creator="Filip Tepper"
                   em:author="Filip Tepper"
                   em:homepageURL="http://blipfox.com/">
    <em:targetApplication RDF:resource="rdf:#$Z8rup2"/>
  </RDF:Description>
</RDF:RDF>
Ten wpis został opublikowany w kategorii Internet, Programy, Techniczne i oznaczony tagami , , , . Dodaj zakładkę do bezpośredniego odnośnika.

9 odpowiedzi na „Jak ożywić BlipFoxa na Firefox4?

  1. plixon001 pisze:

    Sorry, ale jak otworzę plik install.rdf to tam nie wyświetla się Notatnik! Co zrobić? Vista jest niekompatybilna z tym plikiem i nie chce skopiować to do notatnika?

    Proszę o pomoc!

    • inzaghi89 pisze:

      Prawym przyciskiem myszy / otwórz za pomocą. Albo włącz notatnik i za jego pomocą otwórz ten plik. Poza tym, gdzie napisałem że po otwarciu pliku install.rdf ma się wyświetlić notatnik?

  2. Gucman pisze:

    To „ożywianie”.
    A jak odinstalowałem to zanim przeczytałem Twój wpis, to jak go teraz zainstalować?

  3. Bartosz P pisze:

    No i niestety u mnie ani pierwszy ani drugi sposób nie działa :/ zainstalowałem nawet plugin który ma wyłączyć sprawdzanie wersji (Nightly Tester Tools) i dupa blada ;/
    Przy próbie pobrania z blipfox mam info że wtyczka uszkodzona z alternatywnego źródła że niekompatybilne ;/

  4. Pingback: Blipfox na Firefox 4 mi nie działa ;/ · Bartosz Piątkowski blog

  5. Pingback: Blipfox na Firefox 4 działa :) | Bartosz Piątkowski blog - bo każdy ma swoje miejsce w sieci

  6. Pingback: Blipfox na Firefox 4 działa :) | Bartosz Piątkowski blog

  7. bediqus pisze:

    Działa, działa…trzeba tylko trzeba podmienić wersję wtyczki i bez problemu działa nawet na 6.0

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

*